FANDOM


This is the talk page for UNC: Asari Diplomacy.
Please limit discussions to topics that go into improving the article.
If you wish to discuss matters not relevant to article upkeep, take it to the blogs, forums,
chatroom, or discussions module.
Thank you.

Asari Mods Edit

The asari mods do appear eventualy only certain stores will have them, they are biotic amps and omni-tools and are also armali council items. Check back periodicly at certain shops and you will find one eventualy.


Does the Armali license automatically enter your invcentory or do you have to find it at a shop and buy it? If so which one because it wasn't at the C-Sec shop. Oct 2015 70.112.88.73 17:00, October 23, 2015 (UTC)

Tartakovsky logs Edit

I found Tartakovsky could not find the Tartakovsky logs anywhere on Noveria.... anyone have a specific location to look?


S1D3WYZ 10:41, 21 June 2008 (UTC)

You only find them if Noveria is the first planet you go to. The logs are in a terminal in the back corner of the dining room, where the rachni first leap out at you. --Tullis 17:31, 21 June 2008 (UTC)
Is this because the terminals are not enabled for interaction if you have already gotten the Assignment in some other way -- example: On Citadel, talking to Helena before hacking the terminal in the room next to Chellick's will cause that terminal to be disbled -- that is, you can no longer hack it if you already have the Assignment from having talked to Helena. If so, I think this should be stated instead of something along the lines of "the first planet you go to", since that is misleading. You could for example land on Noveria but don't go to Peak 15, then go kill the mercs and get the Assignment that way. Grail Quest (talk) 15:45, February 6, 2014 (UTC)
(Wow, a 6 year gap in the thread!) It probably should say "first plot world you complete" rather than "first world you visit", given what the earlier part of the acquisition paragraph describes. Since presumably you can't get the logs if Nassana has contacted you, even if you haven't gone to talk to her yet -- haven't personally tested that scenario, but from the existing acquisition paragraph it follows that would be true. Cattlesquat (talk) 16:05, February 6, 2014 (UTC)

Unanswered Questions Edit

Having played Mass Effect 1 and 2 across 4 multiple playthroughs i still wasn't able to find the answers to some questions and i hope that the Bioware team can come up with some satisfactory answers for it. Starting wid the fact that it is stated that Reapers are the creators of the mass relays and can manipulate them at will......then how is the Arcturus Fleet able to pass through the citadel's mass relay and retaliate against Sovereign and the Geth (During the battle of the ciadel - Mass Effect 1) ?? Secondly in Mass Effect 2 the collector ship destroys the first Normandy and Shepard dies as a result, then why didn't they simply capture Shepard's dead body then and there itself. Why did they have to make a deal wid the Shadow Broker for delivering Shepard's body.....afterall they could have just taken it .

Thirdly this is for Mass Effect 3 - If the Reapers are able to manipulate the Relays then they can easily make it inaccessible for anyone except them, effectively isolating and shackling the galaxy's myriad species. How does Shepard manage to overcome that? Is it because of the Reaper IFF they collect in Mass Effect 2 or sumthing? If any1 for the Bioware team or infact any member of the forum can answer these i will be gr8ful. Thanx. Ciao.

Your post would be much more appropriate for the Forums, as it doesn't appear to have anything to do with this article about the assignment UNC: Asari Diplomacy. Article talk pages are reserved for discussing the maintenance of articles themselves, and are not suitable locations for general comments and observations. -- Commdor (Talk) 21:56, August 4, 2011 (UTC)
Might I also recommend a blog post or BioWare's forums as other places as well. We do know that people from BioWare do come here from time to time, but we also know they patrol their own forums a lot more. Lancer1289 21:59, August 4, 2011 (UTC)

Glitch?? Edit

I am on my first Mass Effect 1 playthrough, and I just landed on this world. There were no enemies, neither on the planet surface nor in the stronghold. There was nothing there at all except a probe to scan and a few crates to open in the stronghold. The ! informed me I was in the right place, but there was nothing there! The assignment is still there on my mission computer. "Meet with Nassana" is checked off, but "Find Dahlia" is not. So....WTF? It also showed the thorium deposit and the matriarch writings as already being found. Is this a known glitch? I went back to the Normandy and landed again, same result, ghost planet.

Ok here's a quick question, did you ever meet with Nassana on the Presidium? If you did, then this is a glitch that I haven't seen reported anywhere. The only thing I can suggest is to reload your game before you ever talked with Nassana and before she contacted you. Lancer1289 12:43, August 24, 2011 (UTC)

Yes I talked to Nassana on the Citadel. I remembered Thane killing her from ME2 (I had a PS3 and played ME2 first, only recently got an Xbox and ME1).

Well then I would suggest reloading form a point before you talked to her. That usually fixes bugs like this that crop up from time to time. Lancer1289 20:10, August 26, 2011 (UTC)

I already completed the game :P

A very similar glitch just happened to me. I am on my first playthrough as well. I met with Nassana, then landed on Sharjila. When I got to the place on the map where the stronghold was supposed to be there was nothing there at all: no enemies and no stronghold; just an open valley. I then got out of the Mako and all of a sudden the enemies and stronghold magically appeared all around my position! I got back into the Mako and tried shooting the enemies, and the red target marker appeared on them, but my bullets just went straight through them. I could not kill them. I drove away from the valley and came back. At that point I was able to kill the enemies and continue with the mission.

Benjallow 00:59, December 11, 2011 (UTC)

Rejected edit was 100% accurate in my unmodded playthrough Edit

I received the assignment-initiating transmission from Nassana:

  • after leaving Citadel for the first time, ever;
  • shortly after rescuing Liara;
  • before leaving the Artemis Tau cluster after said rescue (while surveying Knossos and Athens, per the Completionist Guide);
  • having not traveled anywhere else (other than the implied having to pass through others to get to Artemis Tau);
  • most definitely having not yet 'returned' to the Citadel.

Therefore my understanding is that the article's instruction to return to the Citadel [before, or in order to receive, the transmission] is unnecessary/slightly misleading. Perhaps the moment of transmission is randomly determined, but my experience indicates that it is not at all dependent on returning to the Citadel. Obviously to advance the assignment once it has been received, one is required to be at the Citadel, but the article implies otherwise as currently worded.

Maybe I edited in a presumptuous manner? But it's an accurate and honest edit, so I'm asking that it be restored. My game is the most recent possible version, digitally downloaded, + BDtS, no mods/tweaks/etc. --Yeti magi 19:02, January 24, 2012 (UTC)
I also recieved this assignment without ever having gone back to the Citadel. I went to Feros first, then while exploring the Artemis Tau cluster on the way to rescue Liara the assignment transmission popped up. Thus, the first line of the "Acquisition" section where it states "After completing a main plot world, visit the Citadel." is wrong, as it is clearly not required to re-visit the Citadel in order to acquire the assignment. I'll edit it to maintain the meaning while ditching the inaccurate info.--Museerouge 22:46, March 23, 2012 (UTC)
Thanks for the backup! :) --Yeti magi 07:46, March 25, 2012 (UTC)

Journal Entry Title Discrepency Edit

On the Xbox 360 version, the Journal entry is titled Asari Diplomacy not UNC:Asari Diplomacy. Can't account for the PC version.

Also, Makes sense as the mission does not occur in "uncharted" worlds. SheepReaper 24.102.211.206 19:41, August 31, 2013 (UTC)

bypass nassana. go straight to sharjila, storm the base, access the computer there. case closed. T̴̴͕̲̞̳̖̼̱͒͛̎͒ͫ̃ͧeͩ̈̽̈҉͓̝̰̼̦̫̤̀͠m̫̪̪̯̻͎̫̅̇̓̇͌̚p̸̙̝̓̓͌ͨ͆ͣͥ̂̕o͒̽͐̽͏̞̬̻͕͔͕͚̰͍͠͞ṙ̢̞͚͈̹̰ͨ̓ͭ̈́̌ạ̢̧̪̹̺̺̣̹̲͂͆̏ͪͨ͒ͭř̹͈͜͠y̷͍̻̜̹̼̾̽̈́e̵̹̼̟̦͚͐̈́͌͘d͉̲̣̻͉̱͗̅ḭ̷̻̆͋̆̓̔͝t̨͍̦̫̗͂̅̍̋̆ͩ͝ộ̫̟̬̳̝̲̾ͫ̒̿ͮ̑̚rͯ̎ͨͭ̄̿̽͛҉̠̫̱̠̘̘̲́ͅ7̩̻ͤͩͨ͝͡8̜̣̙͇̻ͨ͛͛̆͒̆̽̒͐͜͡ ͥ̍̉̃̇ͥ̓ͨ͏̕҉̥̹͓̗̤̠̖̤ (talk) 09:41, September 1, 2013 (UTC)
As for the 'unchartedness' of planets: almost all are (also in the ME universe). This is especially true for worlds related to UNC assignments. Also see this codex entry. — Elseweyr (talk) 09:51, September 1, 2013 (UTC)
So I tried as you said, to re-enter the base, however the computer is unselectable. My journal entry still lacks the UNC: prefix. Bug perhaps? SheepReaper 24.102.211.206 19:52, September 3, 2013 (UTC)
reload a save prior to acquiring the journal entry before i start suspecting you have serious reading comprehension issues. nowhere did i specify to "re-enter" the base. T̴̴͕̲̞̳̖̼̱͒͛̎͒ͫ̃ͧeͩ̈̽̈҉͓̝̰̼̦̫̤̀͠m̫̪̪̯̻͎̫̅̇̓̇͌̚p̸̙̝̓̓͌ͨ͆ͣͥ̂̕o͒̽͐̽͏̞̬̻͕͔͕͚̰͍͠͞ṙ̢̞͚͈̹̰ͨ̓ͭ̈́̌ạ̢̧̪̹̺̺̣̹̲͂͆̏ͪͨ͒ͭř̹͈͜͠y̷͍̻̜̹̼̾̽̈́e̵̹̼̟̦͚͐̈́͌͘d͉̲̣̻͉̱͗̅ḭ̷̻̆͋̆̓̔͝t̨͍̦̫̗͂̅̍̋̆ͩ͝ộ̫̟̬̳̝̲̾ͫ̒̿ͮ̑̚rͯ̎ͨͭ̄̿̽͛҉̠̫̱̠̘̘̲́ͅ7̩̻ͤͩͨ͝͡8̜̣̙͇̻ͨ͛͛̆͒̆̽̒͐͜͡ ͥ̍̉̃̇ͥ̓ͨ͏̕҉̥̹͓̗̤̠̖̤ (talk) 19:59, September 3, 2013 (UTC)

I just went crazy over trying to find this mission because it had the UNC: prefix. Perhaps put the UNC: in parenthesis () or use the pipe | to seperate it giving it two names? ex: UNC: Asari Diplomacy | Asari Diplomacy Brizingr5 (talk) 21:31, October 22, 2013 (UTC)

In the PS3 version, the assignment is also called "Asari Diplomacy" without the "UNC."

Noting the glitch Edit

I just played the assignemnt and at first, I couldn't find the stronghold. It was on the map, but once I arrived on the location, it was no where to be seen. How to solve this glitch is already explained on this talk page, but I noticed it wasn't in the article itself. Shouldn't we mention that? Megadracosaurus (talk) 17:30, October 21, 2015 (UTC)

Confused Edit

"" To acquire these new mods, you can purchase the Armali Council License from Commander Rentola in Virmire: Landing Zone. ""

Implying one must wait until Virmire to actually make use of what the asari lady gave Shepard?

I was able and am able to immediately receive in normal fashion the relevant products upon side-mission completion. No super-long wait where Virmire or R. unlocks stuff.

Is my digital, XBOX Live version cryptically pirated or something? Some of the things reported here don't square with my experience, more and more, I am starting to wonder what is up...—The preceding unsigned comment was added by 75.52.186.148 (talk · contr).