FANDOM


This is the talk page for Citadel: Hanar Diplomat.
Please limit discussions to topics that go into improving the article.
If you wish to discuss matters not relevant to article upkeep, take it to the blogs, forums,
chatroom, or discussions module.
Thank you.

Trigger? Edit

I'm trying to figure out if this mission is glitching. I'm a third through the mission and the second terminal shows up on my map, I am look right at it, yet I can't activate it. Is there a requirement to further the mission that I have not accomplished yet? Such as a sidequest to complete or story mission?--Xaero Dumort 01:25, March 7, 2012 (UTC)

Reloaded an older save and it worked. Not sure what happened, but worth keeping an eye out if anyone else has an issue.--Xaero Dumort 01:38, March 7, 2012 (UTC)

Terminal Edit

Apparently after you check the Spectre's terminal and are supposed to check a second terminal, the latter can be bugged and the player would not be able to activate it. Got no older save to load, found no solution so far.

Same problem here. Apparently this mission gets bugged if you leave the citadel before checking the terminal in the embassy lounge.EDIlicous 17:02, March 7, 2012 (UTC)
I couldn't use the terminal. It seems that you have to do everything directly after talking with Kasumi. In my case, I left the Citadel without using the Spectre's terminal. After activating it later, the other one doesn't work at all. Suuusuuu 01:49, March 8, 2012 (UTC)
I have the same problem, the last one near the docking bay entrance unable to interact.--59.68.10.7 03:57, March 8, 2012 (UTC)
Yes, I also left the citadel only activating the Spectre's terminal. Perhaps there should be a warning about creating a save before starting the mission?--66.183.61.236 16:07, March 8, 2012 (UTC)-

Same problem here as well. I hope Bioware fixes this soon. Ztr9 00:39, March 9, 2012 (UTC)

Acquisition Edit

Finished the game and did everything. For some reason did not recieve the email from 'Agent Bau'.

I got it right after Grissom, but it wasn't available after completing Palaven. I had also completed Aria: Blood Pack. Ea-41905502 04:15, March 16, 2012 (UTC)

Outcome Edit

I've never met Kasumi and the choice for me was: Jondum's life vs. Hanar homeworld.


I Had the same Problem without Kasumi from ME2 it makes for a completely crap conclusion either way. Anyway to get her on your side without playing ME2 first?

Too much text Edit

This mission page should be condensed. Lots of description, relevant info (where to go and what to do) tedious to find in all that text. Trivia could be filled with (some of) the non-essentials. Bravenu3 19:26, March 10, 2012 (UTC)

Um this is a walkthrough, so details are kind of important. Lancer1289 19:50, March 10, 2012 (UTC)
Yes, the where, what and who. But not a rehearsal of the dialogue. http://masseffect.wikia.com/index.php?title=Citadel:_Batarian_Codes is optimal IMHO. Bravenu3 17:49, March 12, 2012 (UTC)
And that will eventually be expanded as well. Walkthroughs here have a lot of detail, from dialogue, to tactics. Lancer1289 18:14, March 12, 2012 (UTC)
The only dialogue included should be that which is relevant to differing outcomes. Including he said/she said or voice over dialogues is just A waste of space, and gets tedious. Most people use walkthroughs when they are stuck, not as a transcript of events. When the player is in the game they will hear the dialogue anyway. We don't need descriptions of scenes that play out regardless of in-game actions/choices. 124.148.254.133 11:59, September 2, 2012 (UTC)

Timed Mission? Edit

I did not finish this mission before the citadel was under attack. It is now greyed out in my journel.

I think it should be mentioned in the wiki page that this mission cannot be completed after Priority: The Citadel II. I wanted to do Jacob's mission first and then do this one to see if the dialogue changed, but because you don't do Jacob until after The Citadel II this is impossible. Can we note this somewhere? - Loz.neo 06:00, April 30, 2012 (UTC)

There is a mention in Priority: Tuchanka mission page, and in some other mission articles that become unavailable after competing Priority: The Citadel II. Added note in all relevant articles, so the issue is now fixed. --silverstrike 06:25, April 30, 2012 (UTC)
Thank you. I didn't see it in those pages - guess I must have missed it. - Loz.neo 07:36, April 30, 2012 (UTC)

Fix Edit

Many topics galore here but I've found a fix for it, at least what I've tried that works for me. This was done on Xbox 360. After Bau is finished talking with you, it is implied that the player should read and enable the quest in the Spectre terminal. I instead decided NOT to enable and went straight to finding the terminals and lo and behold, it worked beautifully. Freakium 03:14, March 11, 2012 (UTC)

Seems to be working with this solution on PC with latest patch. --ReijoRitari 10:24, April 26, 2012 (UTC)

Fix (PC) Edit

Didn't notice the quest was bugged until it was too late. I checked the save game data with Gibbed's Save Editor and in the "Plot" section there are 3 groups pertaining to quests. I found out that the quest ID is 60012 but thats as far as I got. I tried deleting all attributes relating to this quest and adjusted quest counters wherever I found them but I couldn't get the quest to reset. There has to be additional quest data stored somewhere else. Maybe the last version of the save editor doesn't show all data.. I could also have overlooked something, perhaps someone could double-check? --164.61.223.12 09:52, March 13, 2012 (UTC)Akki

This is how i made the terminals work again. I originally took the mission then leaved the Citadel without looking for the terminals. They didn't work anymore when i came back and the mission would not progress. When i realized the bug was there it was too late for me and i made 10 more hours of playtime which made me upset to play again just for one little bugged mission ;-). Now i'm upset a little more because i finished all the available missions and if i go on with the storyline the Hanar Diplomat mission will be not completable anymore (thanks Bioware).

For the fix to work make sure to go to the Citadel and place in front of Bailey Office door, then save again. This is because ME3 saves have a streaming structure and get constantly modified according to the last location where they are saved.

Download Gibbed's Mass Effect 3 Save Editor: http://svn.gib.me/builds/masseffect3/

Load the save and go to the "Raw" tab, on the "Other" section look for "streaming records" then on the far right on the same line press the "..." button to edit the table, a new window will open. Go on the bottom of the list and press "Add", on the right side put "SS_HanarPlot" (without quotes) in the name field and make sure that active is set on "True". Save and load the game again, the terminals should be accessible again and the quest completable (at least it was in my situation). Pilone71 15:05, March 14, 2012 (UTC)

And this isn't permitted in the article for the reason that it is using a mod. Lancer1289 13:00, March 14, 2012 (UTC)
Good Job, that did the trick. Quest is working again! Thanks a lot!

79.199.123.45 19:03, March 14, 2012 (UTC)Akki

@Akki Glad it worked!

@Lancer1289 Gibbed's Mass Effect 3 Save Editor can also be used to mod the game but what i suggested to do in my fix is not. I don't like to cheat and i carefully examined the save structure from a new game without leaving the Citadel, i just found out that was the only missing info. I simple restored back what the bug in this specific quest make the game to early delete (yes ME3 saves structure gets constantly part deleted and part rewritten if you simple change location) from the saves if you leave the Citadel and should not be erased until quest is completed, i think the streaming nature of ME3 saves itself is the source of the problem. I would gladly put on an official patch from Bioware but it's getting too late for me to keep waiting, that's all and have fun! Pilone71 20:57, March 14, 2012 (UTC)

Confirming that this also worked for me! 67.185.92.9 04:28, March 19, 2012 (UTC)

Confirmed it worked for me as well. To clarify though, when you add "SS_HanarPlot" and set as true, do not go back to the game to save and load again. That did not work for me. What did work was after adding it and clicking "OK" I then clicked "Save" at the top of the editor. Then I went back to the game and loaded the new save that I created from the editor. I hope this helps anyone else that may have had the same problem. --Inexus 14:52, March 23, 2012 (UTC)

Unfortunate this didn't work for me. When I open Gibbed's Mass Effect 3 Save Editor and load the save there is NO "other" section. There is only a "uncategorized" section and here I find "streaming". Clicking the [...] leads to a list but when I try using "add" it doesn't let my change the text and adds something like "Gibbed.MassEffect3.FileFormats.Save.Streaming". This is really frustrating.--El Harmakhis 12:03, March 24, 2012 (UTC)

@ El Harmakhis - You are in the right area. Why you do not see the "other" section is because you downloaded a newer version of the editor in which the "other" category was changed to "uncategorized". The "streaming" section there is the right place to edit. Also, you change the text in the box on the right, after clicking "add". Click beside "Name" in the box on the right and there is where you enter "SS_HanarPlot" (no quotes). This will then change the "Gibbed.MassEffect" to "SS_HanarPlot" in the box on the left. Make sure to also click above the Name in the box on the right to set "Active" as "True". From there, Click "Save" at the top of the editor to create a new save in the editor. When you go back to your game and choose load, you should see the new save in your game that you just created in the editor. Select it and hope it works! Good Luck! --Inexus 14:52, March 24, 2012 (UTC)== Fix (PC) ==


It worked for me with the newest version, Thanks for posting the fix! - Delixcroix

This does not work for me. I saved outside Bailey's office, added the SS_HanarPlot thing and set it to 'true' - when I go in-game the mission is still marked as done in my Journal. I am able to access the terminals now, although I of course need to find everything on my own. (old school :p) However, when I am supposed to meet Bau after accessing three terminals, he is not present. The mission effectively stops here. I am going to try to re-do the save edit. --Joffeloff 18:17, March 25, 2012 (UTC)
Okay, doesn't work. Please note that I am very far along. I simply forgot about/gave up on this side mission, and I am now at the point where Sanctuary is my next objective. It seems that once you get past a certain point it is impossible to do this mission no matter what you do to the save game. Very disappointing by Bioware. (again.) --Joffeloff 18:22, March 25, 2012 (UTC)

-May I share my experience. Firstly, Thanks for the fix. It worked for me. The "other" section was named "uncategorized". From there I followed the steps and voila. Finishing the quest now.--bluemary1014 23:22, April 20, 2012, Philippine Time

Just want to post myself, this trick worked! I was seriously getting aggravated at not being able to do anything with this mission, as I couldnt find these 'terminals'...not knowing that they didnt work. Did this mod, and reloaded into the embassies, bam it all worked :D. Was able to go through all the terminals no problem (c embassies, right out the door from docking bay, and end of hallway (section 4)). Thanks for this, will probably be in the patch bioware should be working on...-MEFrenzie101 18:47, April 3, 2012

had a bit of trouble after I did this. in my case when I performed the fix it did not reset the quest back to start, it had allowed me to continue on where I was stuck so if you find id does not work the first time have a check to where you found the bug. you may be able to continue from there. --82.21.19.30 19:13, June 5, 2012 (UTC)


- Just wanted to say the fix worked for me also. This was an annoying one xD glad someone figured out how to fix it. yay no patch from devs in 2 years! Willhelm 55 (talk) 23:01, September 13, 2014 (UTC)

Best of Both Worlds Edit

Assuming you did not complete the DLC with Kasumi Goto, there is another way that you can complete this mission and gain both war assets; saving both Jondam Bau and the Hanar homeworld in the process, assuming you are not averse to using Gibbed's save game editor.

--This assumes you have a save game prior to the final cut scene with Jondam--

  1. Load the save game using Gibbed's
  2. Under Mass Effect 2> Plot> Mass Effect 2> Missions tick "DLC: Kasumi: Kept greybox" [note: I have never done this DLC so I ticked this option on a whim..I do not know if ticking "destroyed greybox" changes the outcome]
  3. Under Mass Effect 2> Henchmen> Tick "Kasumi acquired" and "Kasumi Loyal"
  4. Save the savegame as a new savegame and load it in ME3
  5. Start the cutscence with Jondam. Kasumi should intervene and the mission should complete successfully.


Centlivres 09:25, April 5, 2012 (UTC)Centlivres

Trigger for the Glitch Edit

After a few experiments. I have found that the glitch definitely gets triggered by leaving the Citadel without completing the mission regardless of the number of terminals you have interacted with; 0 or 1 or 2. The only reason most of the players complain it to happen after the second terminal may be because it is highly unlikely for anyone to just leave the Citadel Embassies without activating the terminal there. I suggest updating the relevant section. --NisansaDdS 13:18, May 1, 2012 (UTC)


NEW SOLUTION TO THE CITADEL: HANAR MISSION THAT REALLY WORKS!Edit

The xbox save can be fixed by using a usb, saving your mass effect save to your computer and then using a couple of programs.

First you need to get your save file off your Xbox. Insert a [prefferably empty] memory stick into your Xbox360. Format it to receive Xbox data. Go to your hard drive, select your ME career, and MOVE, not Copy, it to the USB stick.

Next, download the Horizon utility for your PC. Sorry, Mac users.

http://www.xboxmb.com/horizon/

Install, then use Tools>Device Explorer to find your career under Game Saves. Choose Extract Selected File and save it to an "Xbox360" folder on your PC.

As a backup, DUPLICATE THIS FILE somewhere else. Just in case.

Then, in Horizon, use Tools>Package Manager to select your career file on the PC. Choose to Extract your save file in question to your PC. It will have a .xbsave extension.

Next, download Gibbed's Mass Effect 3 Save Editor. This normally only works on PC, but can work with .xbsav files.

http://svn.gib.me/builds/masseffect3/

Run the Editor. Press Open on the top bar, and select the appropriate save file.

Select the Raw tab and scroll down to Other. From here, find the category that says "Streaming" and click on it, then look to the far right of the table for the [...] looking button . Click on that.

Find the "Add" button at the bottom of the box, and create a new entry named "SS_HanarPlot" (no quotation marks!) and set the "Active" option to "True". Hit OK.

Don't forget to press the Save button at the top before closing the editor!

Now go back to Horizon, Tools>Package Manager. Right-click on the save file you just modded, and choose "Replace…". In the browser, choose the file you just fixed in the Save Editor. Then click the red tab "Save, Rehash and Resign" a couple times to make your new Career File be accepted by your Xbox.

Lastly, click the button on the top-right of Package Manager to transfer this modified Career file back to your Memory Stick. Yes, let it save it and replace the file on your memory stick.

Make sure to safely eject the stick from your PC, put it in your Xbox, and MOVE the modified career file back to your Xbox hard drive.

Start ME3, load your file, and the terminal should be active again!

Obviously it'd be nicer to not have to hack the file, and let Bioware patch it, but it's been almost a year and no news. So I hope this helps everyone out until Bioware fixes it themselves. All thanks to the person who created the PC fix and these marvelous utilities.

-RyanMJames 15:11, Dec 3, 2012 (PST)

Another Possible Solution Edit

I found another solution.

First, go to the questprogress and find out which entry is the hanar quest. (For me, it was the last one). In your save, click "View all entries", then go into the save editor and edit a single entry's "Quest Updated" value to true. When the Citadel: Hanar Diplomat mission is listed as new, remove that particular entry. Secondly, go to the raw/uncategorized/streaming/QuestIDs and remove the 60082 number. The questids section is the list of active quests.

This is a quick and dirty reset to the quest. I have yet to see any bugs yet. I'm aware that it can't be used on the page, but anyone who needs to reset the quest, this is a way.

69.67.113.212 08:02, January 22, 2014 (UTC)


^ I think you mean raw/plot/plot/QuestIDs? There is no Quest IDs in uncategorized/streaming :) 109.154.161.180 13:50, July 29, 2015 (UTC)

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.